CrowdRecon is coming: turning hacker reconnaissance into security intelligence
At DEF CON 34, our team introduced something exciting. Something the Intigriti team has been building for months, and our Senior Product Manager, Radu Voloaga,…
At DEF CON 34, our team introduced something exciting. Something the Intigriti team has been building for months, and our Senior Product Manager, Radu Voloaga,…
Australian organisations are experiencing cyber incidents at record rates, with 71% of surveyed organisations reporting an incident in the past 12 months, according to MinterEllison’s…
IT threat evolution in Q2 2026. Mobile statisticsIT threat evolution in Q2 2026. Non-mobile statistics The mobile section of the quarterly cyberthreat report includes statistics on malware,…
SigninLogs | where TimeGenerated > ago(1h) | where ResultType in ("50034", "50126", "700016") or isempty(AppDisplayName) | summarize DistinctClientIDs = dcount(AppId), ResultCodes = make_set(ResultType), Usernames =…
We’re honored to announce that Cloudflare is the only vendor that has been recognized as a Visionary in both the 2026 Gartner® Magic Quadrant for…
Payroll Pirates are using phishing emails to seize Microsoft 365 sessions and search payroll-related mailboxes. The campaign turns a voicemail alert into a route for…
Business leaders tend to view cybersecurity as a technical discipline, but its real impact is financial. When a cyber incident occurs, it doesn’t just disrupt…
Anthropic’s Claude Opus 5 has significantly reduced the likelihood of a successful indirect prompt injection (IPI) attack, bringing it down to 2% over 15 attempts…
OpenAI’s internal evaluation of its upcoming model, Astra, found significant advances in agentic coding and cybersecurity, leading the company to conclude that it cannot rule…
Last week on Malwarebytes Labs: AI chat bots are sliding into League of Legends friend requests Meta ordered to pay $942 million over harm to…
OpenAI has announced that it’s pausing some “internal activities” involving its upcoming artificial intelligence (AI) model Astra after an internal evaluation found it had made…
Levi Strauss cyberattack has exposed certain corporate information after an unauthorized third party gained access to company files through compromised employee computers, according to a…